6
64

Bài 16. Giao thức cấp IP động DHCP

1. Cơ chế hoạt động

a. Dynamic Host Configuration Protocol

Giao thức DHCP cung cấp cơ chế cấp phát IP một cách tự động cho các thiết bị đầu cuối như là: máy tính, camera, mobile phone,…

Theo nguyên tắc hoạt động của hạ tầng mạng, để một máy tính có thể truy cập ra ngoài Internet thì điều đầu tiên cần thiết lập đó là IP cho máy tính.

Có 2 phương thức để gắn IP cho máy tính:

  • Gán thủ công (nhiều thiết bị dễ bị trùng IP thì sẽ không đi được ra ngoài Internet).
  • Để thiết bị sinh IP tự động từ DHCP Server rót xuống (cấp phát tự động, không bị trùng nhau).

Trên cùng hạ tầng mạng, ta vừa có thể chọn phương thức gán IP tĩnh xen lẫn phương thức sinh IP một cách tự động từ DHCP Server.

Trước khi một máy tính có thể sinh IP một cách tự động từ DHCP Server rót xuống, chúng ta cần kích hoạt dịch vụ DHCP Client trên thiết bị này.

b. Tiến trình của DHCP

Khảo sát tiến trình xin địa chỉ IP của một máy tính:

  • Đầu tiên, khi máy tính vừa khởi động thành công hoặc chúng ta vừa cắm cáp cho thiết bị này thì nó sẽ gửi 1 bản tin Discover bằng cách broadcast bản tin này đến tất cả con DHCP Server trên hệ thống mạng sẽ nhận được bản tin xin IP.
  • Đứng ở quan điểm DHCP Server, hễ có một người xin địa chỉ IP thì nó sẽ cấp cho thiết bị này một cái địa chỉ IP dựa vào địa chỉ MAC của thiết bị.
  • Chẳng hạn, đứng ở quan điểm DHCP Server A sẽ lấy dãy IP là 172.16.0.1-50, thông thường thì nó sẽ lấy IP đầu tiền là 172.16.0.1 rồi cấp phát cho con DHCP Client, nó cấp xuống cái bản tin IP bằng offer.
  • Đứng ở quan điểm DHCP Server B, nó được thiết lập để cấp dãy IP 172.16.0.51-100 thì lấy này nó sẽ lấy địa chỉ 172.16.0.51 để cấp về cho máy tính thông qua bản tin offer.
  • Đứng ở quan điểm DHCP Client, nó nhận được tới 2 địa chỉ IP thông qua bản tin Offer thì lúc này nó nhận được bản tin từ Server A trước rồi sau đó mới nhận được bản tin từ Server B thành ra nó sẽ quyết định sử dụng địa chỉ IP của bản tin offer nào mà nó nhận đầu tiên đó là 172.16.0.1. Và cuối cùng, nó sẽ quyết định sử dụng địa chỉ IP 172.16.0.1.
  • Tuy nhiên, tại thời điểm này, máy tính vẫn chưa thật sự gán địa chỉ 172.16.0.1 lên trên card mạng. Nó cần phải xác nhận xem là cái IP này đã có người sử dụng hay chưa bằng cách là gửi tiếp một bản tin Request bằng cách broadcast ra. Bản tin broadcast ra ngầm báo cho con Server biết rằng là nó quyết định chọn IP 172.16.0.1 chứ không phải là 172.16.0.51. Có nghĩa là con Server B được quyền lấy địa chỉ 172.16.0.51 cấp cho thiết bị đầu cuối khác.
  • Còn đứng ở quan điểm DHCP Server A nó thấy rằng trong bản tin request từ DHCP Client gửi tới, PC quyết định sử dụng 172.16.0.1 và lúc này nó sẽ ghi chú lại cái địa chỉ IP này đã được cấp cho thiết bị có địa chỉ MAC của máy DHCP Client, tức là nó không được quyền cấp IP cho 1 thiết bị đầu cuối khác nữa.
  • Lúc này Server sẽ xác nhận về cho máy tính một bản tin gọi là ACK. Bên cạnh những thông tin địa chỉ IP thì DHCP Server còn cấp cho máy tính cả thông tin subnetmask, default getway và cả thông tin DNS trong bản tin ACK.

Quá trình sinh IP của một máy tính thường diễn ra thông qua bốn giai đoạn:

  • Giai đoạn đầu tiên, máy tính sẽ gửi bản tin Discover dưới dạng broadcast tới port đích là port 67, thực ra bất kỳ thiết bị DHCP Server nào khi nhận được bản tin xin IP này nó sẽ hồi đáp về bản tin Offer unicast trực tiếp về địa chỉ MAC của DHCP Client.
  • Sau đó máy tính sẽ tiếp tục gửi một bản tin khác là Request dưới hình thức broadcast.
  • Cuối cùng, Server sẽ xác nhận về cho máy tính bản tin là ACK và bản tin này cũng unicast trực tiếp về cho địa chỉ MAC của DHCP Client thông qua port 68.
  • Mọi người có thể thấy, thông thường chỉ cần trải qua 2 bước là Discover và Offer mà thôi. Tuy nhiên, nếu mà trên hệ thống mạng của chúng ta có nhiều con DHCP Server thì nó cần phải gửi thêm bản tin Request để cho các thiết DHCP Server khác biết rằng là PC quyết định sử dụng địa chỉ IP nào nếu PC nhận được nhiều bản tin Offer.
  • Và đến giai đoạn cuối cùng, cái Server nào mà quyết định cấp IP cho máy tính thì nó sẽ phải đứng ra để soạn thảo bản tin ACK và unicast trực tiếp về cho máy tính để hoàn tất quá trình xin địa chỉ IP.

2. Cấu hình DHCP Server trên Cisco Router

a. Lệnh để phân bổ IP tự động

Câu lệnh dãy địa chỉ mà Router sẽ không cấp cho Client DHCP.

Form các câu lệnh để thiết lập dãy địa chỉ IP trên DHCP Server.

=> Lúc này chỉ giao tiếp nội bộ với nhau. Để có thể truy cập ra ngoài Internet, bên cạnh cấp phát địa chỉ IP, subnetmask, ta cũng cần cấp cho các thiết bị này tham số default getway.

=> Lúc này, Router kiêm luôn 2 chức năng đó là DHCP Server và Router.

=> Các thiết bị trong LAN có thể ping ra ngoài Internet, nhưng vẫn chưa lướt web được. Để cho phép lướt web, chúng ta cần cấp các thiết bị này thêm tham số dns server.

=> DHCP Server sẽ cấp phát IP cho các máy tính trong một khoảng thời gian nhất định.

b. Thực hành

Ví dụ 1:

Trên Packet Tracer, xây dựng mô hình như hình trên:

Bước 1: Khởi tạo địa chỉ IP cho Interface g0/0 và g0/1

Interface g0/0:

Interface g0/1:

Bước 2: Thiết lập các 2 bể IP cho tương ứng cho interface g0/0 và interface g0/1

Interface g0/0:

Interface g0/1:

Bước 3: Chuyển chế độ DHCP Client cho các PC.

Ví dụ 2:

Xây dựng sơ đồ trên Packet Tracer theo ví dụ 2:

Bước 1: Tạo 2 Sub Interface trên Router

No shutdown Interface vật lý.

Router(config)#int GigabitEthernet0/0
Router(config-if)#no shutdown

Tạo Sub Interface VLAN 10

Router(config)#int GigabitEthernet0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 172.16.10.254 255.255.255.0
Router(config-subif)#exit

Tạo Sub Interface VLAN 20

Router(config)#int GigabitEthernet0/0.20
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 172.16.20.254 255.255.255.0

Bước 2: Thiết lập bể IP để cấp phát IP tự động của trên Router.

Cấp IP tự động cho VLAN10

Router(config)#ip dhcp pool LAN10
Router(dhcp-config)#network 172.16.10.0 255.255.255.0
Router(dhcp-config)#default-router 172.16.10.254
Router(dhcp-config)#dns-server 8.8.8.8

Cấp IP tự động cho VLAN20

Router(config)#ip dhcp pool LAN20
Router(dhcp-config)#network 172.16.20.254 255.255.255.0
Router(dhcp-config)#default-router 172.16.20.254
Router(dhcp-config)#dns-server 8.8.8.8

Bước 3: Thiết lập kết nối Trunk ở Switch.

Switch(config)#int GigabitEthernet0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all

Bước 4: Tạo VLAN và gán các Interface vào VLAN.

Tạo VLAN 10 và VLAN 20.

Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit

Gán interface f0/1 vào VLAN 10.

Switch(config)#int f0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit

Gán interface f0/2 vào VLAN 20.

Switch(config)#int f0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit

Bước 5: Chuyển sang DHCP Client cho các PC.

3. Cấp IP cố định cho các thiết bị bằng DHCP Server

Ta có sơ đồ như sau:

Yêu cầu: Cấp phát IP tự động từ Router cho các PC, riêng máy in thì được cấp 1 IP riêng để đảm bảo đồng bộ với các thiết lập sau này. Với cấu hình cấp IP riêng cho máy in, ta sẽ có form các lệnh.

Xây dựng sơ đồ tương tự hình trên trong Packet Tracer:

Bước 1: Thiết lập IP cho interface g0/0.

Router(config)#int GigabitEthernet0/0
Router(config-if)#ip address 10.0.0.254 255.255.255.0
Router(config-if)#no shutdown

Bước 2: Cấu hình DHCP pool cho LAN.

Router(config)#ip dhcp pool LAN1
Router(dhcp-config)#network 10.0.0.0 255.255.255.0
Router(dhcp-config)#default-router 10.0.0.254
Router(dhcp-config)#dns-server 8.8.8.8

Bước 3: Cấu hình DHCP pool cho Host (Printer).

Router(config)#ip dhcp pool Host1
Router(dhcp-config)#host 10.0.0.1 255.255.255.0
Router(dhcp-config)#client-identifier 0108.00AA.AA11.11
Router(dhcp-config)#default-router 10.0.0.254
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#lease 1 0 0

Với 01 là mạng Ethernet LAN, không phải token bring.

4. Cấu hình chức năng DHCP Relay chuyển tiếp lưu lượng xin IP

DHCP Relay hay còn còn gọi là quản lý tập trung công việc cấp IP tự động. Với chức năng này, việc quản lý và các phát IP từ tuyến trên về các tuyến dưới trở nên dễ dàng hơn. Qua đó, việc bảo trì sự cố hay có những thay đổi không mất nhiều thời gian vì chỉ dùng một DHCP Server để quản lý.

Ta có sơ đồ sau:

Dựa vào sơ đồ hình dưới, việc cấp phát IP từ Router R2 được “nhường” lại cho Router R2 với địa chỉ IP của interface f0/2 là 172.16.0.2.

Ở interface f0/1 của Router R2, cần khai báo lệnh để nhượng quyền:

interface f0/1
ip helper-address 172.16.0.2

Thực hành:

Để làm rõ hơn ví dụ trên, cần đi vào thực hành để nắm rõ các bước. Ta lập sơ đồ trong Packet Tracer dựa theo hình trên.

Bước 1: Thiết lập đỉa chỉ IP cho các interface của 3 Router.

Router R1 (DHCP Relay):

Router(config)#int GigabitEthernet0/0
Router(config-if)#ip address 10.0.0.254 255.255.255.0
Router(config-if)#no shutdown

Router(config)#int GigabitEthernet0/1
Router(config-if)#ip address 20.0.0.253 255.255.255.0
Router(config-if)#no shutdown

Router R2 :

Router(config)#int GigabitEthernet0/0
Router(config-if)#ip address 20.0.0.254 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#int GigabitEthernet0/1
Router(config-if)#ip address 20.0.0.253 255.255.255.0
Router(config-if)#ip address 172.16.0.3 255.255.255.0
Router(config-if)#no shutdown

Router R3 (DHCP Server):

Router(config)#int GigabitEthernet0/0
Router(config-if)#ip address 172.16.0.2 255.255.255.0
Router(config-if)#no shutdown

Bước 2: Thiết lập định tuyến cho 3 Router.

Router R1 (DHCP Relay):

Router(config)#ip route 20.0.0.0 255.255.255.0 20.0.0.254
Router(config)#ip route 172.16.0.0 255.255.255.0 20.0.0.254

Router R2:

Router(config)#ip route 10.0.0.0 255.255.255.0 20.0.0.253
Router(config)#ip route 172.16.0.0 255.255.255.0 172.16.0.2

Router R3 (DHCP Server):

Router(config)#ip route 20.0.0.0 255.255.255.0 172.16.0.3
Router(config)#ip route 10.0.0.0 255.255.255.0 172.16.0.3

Bước 3: Thiếp lập nhường quyền cấp phát IP ở Router R1 (DHCP Relay).

Router(config)#int GigabitEthernet0/0
Router(config-if)#ip helper-address 172.16.0.2

Bước 4: Thiếp lập dhcp pool ở R3, đặt network ở interface R1.

Router(config)#ip dhcp pool LAN1
Router(dhcp-config)#network 10.0.0.0 255.255.255.0
Router(dhcp-config)#default-router 10.0.0.254
Router(dhcp-config)#dns-server 8.8.8.8

Show Comments

No Responses Yet

Leave a Reply